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About this Guide
The images and topics contained in this guide are not representative of every GlobalLink® product installation.
Each GlobalLink product installation is configured to meet the needs of the intended users, who may or may not
require certain features and options. Therefore, the features and options covered in this guide may differ from
those available on your GlobalLink product installation.

Conventions

Typographical
The following table explains the typographical conventions used in this guide.

Bold User interface controls, commands, and keywords in body text.

italic Represents an input field where user input is expected.

<…> Generic parameters that must be replaced by specific code or text.

Icons
The following table explains the icon conventions used in this guide.

Note:
This icon designates a note or helpful suggestion or reference relating to the surrounding text.

Best Practice:
This icon designates a suggestion for best practice relating to the surrounding text.

Alert:
This icon designates a warning or alert relating to the surrounding text. In this situation, the user
should exercise caution to avoid an undesirable result.
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1. About GlobalLink Connect
GlobalLink Connect serves as a bridge between your back-end systems and our industry-leading Globalization
Management Suite, allowing you to use the full functionality of your CMS, DMS, e-commerce, PIM, and database
platforms to manage multilingual content.

Globalization Management Suite
The GlobalLink Globalization Management Suite (GMS) is a modular set of translation technology products that
provide enterprise solutions for organizations. It consists of the following server components:

• GlobalLink Project Director—An automated translation workflow system that leverages and
communicates with the other GlobalLink products through a published Web services API

• GlobalLink TM Server—A robust, scalable server-based translation memory solution

• GlobalLink Term Manager—A web-based terminology management tool that allows any translation
manager to modify, review, search, or delete existing terms

• GlobalLink TransStudio Online—A web-based translation tool that offers translators instant access to
translation memories and terminology lists

• GlobalLink TransStudio Review—A web-based translation review tool with an intuitive user interface that
allows translated content to be reviewed quickly and effectively

• GlobalLink Translation & Review Portal—A web-based, collaborative application that streamlines the
linguistic review process

The integration with AEMP involves Web services communication between AEMP and GlobalLink Project Director
(PD).

GlobalLink Connect for AEM
GlobalLink Connect for AEM, referred to as AEMP, integrates seamlessly with AEM providing the following
functions:

• Support of multiple configurations

• Integration with standard and non-standard languages and structure

• Allowing synchronization of source and target

• Providing on-page review

• Allowing granular control of synchronization

• Providing translation memory updating tools

• Sending pages, tags, and binaries for translation

AEMP PD Localization Workflow
The AEM, AEMP, and Project Director (PD) interaction workflow:

1. A web page is created or updated in the AEM repository.
2. The web page is sent to PD manually from AEM using workflows through AEMP.
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3. The workflow installed with the package is GlobalLink Recursive. This workflow sends the components
configured on the selected page as well as all referenced pages. If you want to embed translation into a
different workflow, contact your AEM support representative.

 Other available workflows are:

• GlobalLink Single—The workflow only sends components configured on both the source and
target page. Components that exist on the source page but not the target page are excluded.

• GlobalLink Recursive—The workflow sends those components that are configured on the
selected page including, the referenced pages, and creates missing components on the target
pages.

• GlobalLink Recursive Split—The workflow sends a page as well as along with all pages
referenced on it. This action splits the file, so each page is a unique XML file while remaining a
single submission.

 AEM 6.3+ users should continue to use the Granite versions of each workflow. And AEM 6.4 and 6.5
users should use the new adaptor workflow location built during the adaptor workflow configuration.
Refer to your administrator.
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2. Get Started
This section describes the AEMP installation requirements and the adaptor user interface.

 All installation and configuration files are in the installation package provided by GlobalLink. You can
also access the package through Adobe Experience Manager (AEM) Package Share.

Use Requirements
Use Adobe Experience Manager (AEM) to connect to Project Director (PD) with the GlobalLink AEMP adaptor.
Have the following data ready before you connect AEM to PD for both staging and production server types:

• PD URL

• User name

• Password

• Project short codes

• Default classifier

 
User credentials are client-specific. Do not share credentials.

Software Requirements
The requirements described must be met to complete the AEMP Adaptor installation.

Product Versions

AEM AEM 6.5.0 (SP1 and higher), 6.4.0 (SP1 and higher), 6.3.0 (SP1
and higher)

GlobalLink Project Director 4.19 or later

JDK 1.8.0 or later

Installation Prerequisites
You must meet these installation prerequisites before installing the adaptor:

• Log in with system administrator privileges

• Have the AEMP adaptor package ready to install

• Create a language copy of the master site in AEM for each required language

• Map AEM users

Explore the User Interface
You can initiate and monitor content translation requests from within AEM using GlobalLink AEMP. Access AEMP
by clicking the AEM Navigation Pager, from the GlobalLink menu.
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Adobe Experience Manager
You can access the GlobalLink menu from both the AEM Navigation Pager—Adobe Experience Manager and
the GlobalLink Translation button.

GlobalLink Menu

The available functions of the GlobalLink menu are:

• Configuration—Enter a variety of adaptor settings.

• Repositories—Enter a variety of repository settings.

• Submissions—Manage your submissions.

• TM Updates—Manage your translation memory.

• Synchronization Jobs—Align all of your non-translatable nodes.
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GlobalLink Action Page

The actions on the GlobalLink menu are:

Action Explanation

Actions Bar • Create—Generate a submission.

• Create from CSV—Generate a submission from a CSV file.

• Clone Submission—Copy an existing submission to resend.

• Detail—Display the details for the selected submission.

• Start Submission—Export a submission to Project Director (PD).

• Re-Open—Change the submission to Sent to enable it for downloading.

• Reimport—Download a submission from PD.

• Edit—Modify a submission.

• Delete—Remove a submission from the dashboard.

• PD Statistics—Retrieve your submission statistics from PD.

• Cancel Submission—Remove the selected submission from PD.

• Archive—Move a submission from the dashboard to the archive.

• Filter—Limit the list of submissions to a select criteria.

Content List Display of all submissions.
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3. AEM System User Setup
You must create, assign permissions, and map the AEM system users before installing the AEMP adaptor. If you
map your system users after installation, you must reinstall the adaptor.

Create an AEM System User
To create an AEM system user:

 1. Log in as system administrator.

 2. Go to Content Repository Extreme at:

http://localhost:4502/crx/explorer/index.jsp

 3. Click User Administration.

 4. Click Create System User.

 
Do not click Create User by mistake.

 5. Enter gl-service in the user ID field.

 6. Click the green check mark at the side.

 7. Click Close.

The system user is created.

Assign User Permissions
You must assign user permissions for each user you create.

To assign user permissions:

 1. Go to:

http://localhost:4502/useradmin

 2. Enter gl-service in the search field.
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 3. Double-click gl-service to open the user information properties.

 4. On the Permissions tab, select only the Read permission for the root folder.

 5. Select the Modify, Create, and Delete permissions for the other folders in the root folder.

For first-time adaptor installations, provide full permissions to /apps/. You can change to specific nodes after
adaptor installation.

• Update the permissions for the /apps/globallink-adaptor/ node immediately after completing
installation.

• Select permissions for /content/ and, or necessary sub-nodes, such as the, we-retail site

• Permissions for workflows:

◦ If AEM 6.3—Select permissions for /etc/workflow/models/globallink-adaptor/ and
  /etc/workflow/models/instances/
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◦ If AEM 6.4 or 6.5—Select permissions for /var/workflow/models/globallink-adaptor/
and /var/workflow/models/instances/

• Permissions for tags:

◦ If AEM 6.3—Select /etc/tags/ or necessary sub-nodes, such as, we-retail site.

◦ If AEM 6.4, 6.5 or higher—Select /content/cq:tags/ or necessary sub-nodes, such as,
  we-retail site.

 6. Click Save.

The user is assigned the new permissions and added to the Repository folder.

Create a User Mapping
To create a user mapping:

 1. Go to Web Console Manager at:

http://localhost:4502/system/console/configMgr/

 2. Search for Apache Sling Service User Mapper Service.

 3. Click + and add the following to Service Mappings:

gs4tr-globallink-adaptors-aem-bundle:gl-service=gl-service

 4. Click Save.

The new user mapping is created and saved.
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4. AEMP Adaptor Installation

Preinstallation from 5.8.x and 5.9.x
This version has a new location of the Project Director (PD) connection configuration node and adaptor data in
the /apps/globallink-adaptor folder. If you are upgrading from 5.8.x or 5.9.x, you must perform these
preinstallation upgrade steps.

To upgrade your installation:

 1. Backup to an AEM compatible zip package, the content of:

/libs/globallink-adaptor/config/repositories

 2. Backup to an AEM compatible zip package, the content of:

/libs/globallink-adaptor/submissions

Your upgrade is complete.

 
The backups are used in the event of folder content loss during the upgrade.

Install the Adaptor
Before installing the adaptor, you must meet all software prerequisites. Refer to Software Requirements.

 Use installation and configuration files from one of two locations: the installation package provided by
GlobalLink or the AEM Package Share.

To install the adaptor:

 1. Using the package manager, upload the GlobalLink-Connect Plus-x.x.x package to the AEM instance.

 2. Click Install.

 3. Go to the web console manager:

http://localhost:4502/system/console/configMgr

 4. Search for and open the Apache Felix Event Admin Implementation file.

 5. Set the Timeout to 15000.

 6. Close Apache Felix Event Admin Implementation.

 7. Locate and open the Apache Sling GET Servlet configuration, then verify that JSON Max Results is set to a

minimum of 1000.

 8. Close the Apache Sling GET Servlet.

 9. Locate and open the Day CQ Link Externalizer configuration, then verify that the local domain URL matches

the domain and port of AEM author access to facilitate the Preview Feature.
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 10. Close the Day CQ Link Externalizer configuration.

 11. Locate and open CRXDE Lite.

 12. Do one of the following:

• If AEM 6.4 or 6.5—Remove

◦ /etc/workflow/models/globallink-adaptor-* and

◦ /etc/workflow/scripts/globallink-adaptor

• If AEM 6.3—Remove

◦ /var/workflow/models/globallink-adaptor-* and

◦ /apps/workflow/scripts/globallink-adaptor

 13. Verify:

a) Removal of /libs/globallink-adaptor/

b) Restoration of repositories and submissions from old version

• /apps/globallink-adaptor/config/repositories/

• /apps/globallink-adaptor/submissions/

The AEMP adaptor is installed.

 If you receive a CSRF error when attempting to view the GlobalLink UI, add:

http://<aem_url>/(bin|apps)/globallink-.*

Apache Sling Referrer Filter > Allow Regexp Host and restart your AEM instance.

Install the Touch Editor Module
The Touch Editor module is an independent module used to submit content from the Touch Editor in AEM.

To install the module:

 1. Go to the Package Manager.

 2. Upload the GlobalLink Connect Plus Touch Editor – x.x.x package into your AEM instance.

 3. Click Install.
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Configure AEM Dispatcher Module
If you are using AEM Dispatcher as a caching or load balancing tool, you can filter the adaptor path to prevent
it always being cached on AEM. This eliminates adaptor upgrades and changes from being replicated in the
Dispatcher configuration.

To install the Dispatcher module:

 1. Open the AEM Dispatcher filter configuration, file and add:

/0007
{
    /glob "/apps/globallink-adaptor/*"
    /type "deny"
}

 2. Save and close the file.

The adaptor is whitelisted on the AEM Dispatcher configuration.

Uninstall the Adaptor
To uninstall the adaptor:

 1. Go to Package Manager > GlobalLink package.

 2. Click Uninstall.

The adaptor is uninstalled.
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5. Assign Non-Admin User Permissions
After you have installed the adaptor, you must assign permissions to all non-administrator users.

To assign non-administrator user permissions:

 1. Go to: 

http://<localhost>:4502/useradmin

 2. Search for groups or users using the search bar.

 3. Double-click the group or user to open the user information in the right pane.

 4. On the Permissions tab, select Read permissions—at the minimum—to the /apps/globallink-adaptor

folders.

The user permissions are assigned.
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6. AEMP Adaptor Configuration
You can configure your AEMP adaptor through the Configuration page.

Configure General Connection Settings
You can configure the connection between the adaptor and Project Director (PD).

 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

To configure general connection settings:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the General tab.
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 3.  Enter data in the general adaptor configuration option fields.

Required fields are marked with a red asterisk.

 Field Action

 Web Services URL Enter the URL for the PD instance that is connected to AEM followed by /
services, such as, https://yourPDserver.translations.com/PD/
services.

 Username Enter your PD instance credentials for creating submissions.

 Password Enter the PD user password.

 Scheduler period Select the frequency in minutes to for AEM to poll PD for completed
submissions.

 Submissions per import Select the number of submissions in each import for AEM to poll PD for
completed submissions.

 Environment Select client AEMP environment connection source as: Dev, QA, Staging,
or Production

 Append daytime to client
identifier

Select to enable automatic PD cancellation of old submissions when you
submit a new version.

 4. Click Action > Save.
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The general connection settings are configured.

Configure Proxy Server Settings
You can configure a proxy server for the adaptor and Project Director (PD) interaction.

 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

To configure a proxy server:

 1. On the AEM Navigation Pager dashboard, click Configuration.
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 2. On the Configuration dialog, click the Proxy tab.

Required fields are marked with a red asterisk.

 Field Action

 Enable proxy server Select to enable the proxy server.

 Host Enter your proxy server host name.

 Port Select your proxy server port number.

 Username Enter your user ID for proxy authentication.

 Password Enter password for proxy authentication.

 3. Click Actions > Save.

The proxy server settings are configured.

Configure Dashboard Appearance Settings
You can configure the appearance of the adaptor dashboard.
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 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

To configure the dashboard appearance:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the Appearance tab.

Required fields are marked with a red asterisk.

 Field Action

 Repositories per page Select the number of repositories visible on a given page.

 Submissions per page Select the number of submissions visible in a page.

Note: Multiple targets within one submission are counted as a single
submission.

 TM updates per page Select the number of translation memory (TM) updates visible on a given
page.

 Synchronization Jobs per
page

Select the number of synchronization jobs visible on a given page.
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 3. Click Action > Save.

The dashboard appearance settings are configured.

Configure Log Setting
You can configure the logging level for each repository.

 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

To configure the logging level for a repository:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the Log tab.

Required field is marked with a red asterisk.

 Log Level Select log level to be downloaded. The options are Info and Debug.

 Preview Log Click to preview the current log.
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 Download Log Click to download the current log to your download folder.

 3. Click Actions > Save.

The logging level is configured.

Configure Users Setting
You can specify which users can view specific submissions using the Users option on the Configuration page.

 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

To configure user settings:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the Users tab.

Enable submission user filtering Select to filter user names that should see all submissions.

List of user names Enter the IDs of those users with visibility to all submissions.
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Those users not listed here can only see their submissions on the dashboard.

 3. Click Actions > Save.

The user settings are configured.

Configure Preview Server Settings
You can configure your preview server settings.

 Contact your GlobalLink representative for your PSS URL, PSS Username, PSS Password, Org ID,
and Client ID identifiers. These identifiers are unique to your account.

 If your site requires different configurations, you can create additional repositories with unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

 
Make sure that your entries contain no blank spaces before saving them.

To configure preview server settings:

 1. On the AEM Navigation Pager dashboard, click Configuration.
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 2. On the Configuration dialog, click the Preview Server tab.

 Field Action

Preview Server URL Enter the URL of the Preview Server instance that hosts the preview of the
HTML pages sent for translation:

• Staging—https://connect-dev.translations.com/api/

v1/file/context/upload

• Production—https://connect.translations.com/api/v1/

file/context/upload

PSS User Enter the preview server user ID.

PSS Password Enter the preview server password.

Org ID Enter the unique token identifier for your preview server.

Client ID Enter the unique token identifier being the Org ID joined by a forward slash
("/") to your Client ID for use as a connection key to your preview server.

AEM User Enter an AEM user ID with administrator permission, used to impersonate
the fetching of each HTML page during submission creation.

AEM Password Enter an AEM user password.
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 Field Action

 Additional value to the
end of AEM page url to be
previewed

(Optional) Enter any parameters to be passed with the URL for use in
assembling the preview. For example, ?wcmdisabled=true.

Remove preview packages
after submission creation

Select to remove ZIP files with the pages preview after the submission is
created and sent.

 3. Click Actions > Save.

The preview server settings are configured.

Configure Preview Server Filter
You can configure your preview server to exclude selective files in the preview snapshot.

To configure preview server filters:

 1. In CRXDE, browse to /apps/globallink-adaptor/config/.

 2. Create an nt:unstructured node named pss.

 3. On this pss node, create a String[] property named ignoreFiles.

 4. Add your list of file names or name-patterns for exclusion.

For example:

• etc_designs_refresh_assets.js

• connect.facebook

 5. Save the changes in CRXDE.

The preview server filters are configured.

Configure Workflows Setting
You can configure your specific workflow folder to customize the Workflow on Delivery list.

 Contact your GlobalLink representative for your PSS URL, PSS Username, PSS Password, and
Client ID identifiers. These identifiers are unique to each client.
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To configure a workflow model connection settings:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the Workflows tab.

 3. Enter your workflow models path for AEMP to use. If this workflow path is blank, AEMP lists all workflow

models.

 4. Click Actions > Save.

The workflow model connection settings are configured.

Configure Permissions Setting
You can configure permissions, for the specific Project Director (PD) projects, by users and usergroups.

 Contact your GlobalLink representative for the list of project shortcodes that you need to assign
permissions. These project codes are unique to each client.
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To configure permissions by users and usergroups:

 1. On the AEM Navigation Pager dashboard, click Configuration.

 2. On the Configuration dialog, click the Permissions tab.

 3. Enter the submitter user names (such as, username1) and usergroups (such as, AEM000024,AEM000027) in

to the Enter the users and project shortcodes to delegate permissions. input area.

 4. Click Actions > Save.
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The permissions by user and usergroup are configured.

 
These permissions are visible when users create submission requests.

 If you activate this feature, make sure that every user name and usergroup intended to configure and
create submissions is listed here with appropriate projects codes assigned.
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7. AEMP Site Repository Configuration
You can configure the AEMP site repository through the Repositories page.

Configure General Repository Settings
You can configure the general settings for each repository.

To configure the repository general settings:

 1. On the AEM Navigation Pager dashboard, click Repositories.

 2. In the Repositories List, select a repository, then click Edit.

 3. On the Edit Repository Configuration dialog, click the General tab, then enter the settings.

Required fields are marked with a red asterisk.



7. AEMP Site Repository Configuration GlobalLink® Connect for AEM Connect Plus

Copyright © 2020 Translations.com, Inc. Confidential Page 31 of 81

Setting Action

Repository path Verify the auto-populated repository path.

Default submission name
pattern

Enter the default name pattern for submissions as a function of the path to
the page.
Content between the forward-slashes refers to the current folder in the
pathname. A hyphen after the slashes acts as a separator, using the
following dot schema:

• None—Exclude the submitted page name

• One—Include the submitted page name

• Three—Include the submitted page name and number of parent page
names equal to the total number of dots

For example:
//.-/.-.

Locate results in the submitted page path:
/content/geometrixx/en/products/mandelbrot/overview

name: geometrixx_mandelbrot-overview.

Default submission status Select the default submission status in AEM.

• NOT READY—Submissions are created but not sent to PD
immediately. You are given time to review and make changes before
sending the submission to PD.

• READY—Submissions are created and sent immediately to PD.

Project name Enter the default Project Director (PD) project name for the submissions.

Default Classifier Enter the default file classifier.

Workflow on delivery Select the workflow that must be triggered upon return of the translation to
AEM, such as Adobe PLW.

Target rules Set rules to determine how the adaptor selects the target path of a translated
component.
You can set target rules to replace a part of the path with a different value
depending on the target language. For example:

• $PATH variable—Page, Experience fragments, DAM assets, i18n,
and commerce translation use $PATH(@replace($SRC_LANG,
$TGT_LANG)) to replace the source with the target locales to allocate
the translations in the respective target folders on the specified path.
For additional extended use cases, see, Extend Target Rules.

• $FILE_NAME variable—The DAM Metadata translation uses
$FILE_NAME(@replace($EXTENSION, -$TGT_LANG

$EXTENSION))

• $PROPERTY variable—The tags translation uses
$PROPERTY(@replace($PROPERTY,$PROPERTY.$TGT_LANG))
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Setting Action

Ignore Node with List a value and property that protects the content of these nodes and their
children from the translation process instead of blocking a single property.

Sort page nodes
alphabetically on
submission creation screen

Select to list the tree items alphabetically on the submission create page.

Sort pages by modified date
on submission creation
screen

Select to list the tree items from newest to oldest modified date.

Activate Split Submission
by default

Select to have the Split Submission option selected by default on the
submission create page.

Use sling:key to show
dictionary items on the
content tree

Select to display the sling:key property based dictionary items on the
content tree.

 4. Click Actions > Save.

The general repositories settings are configured.

Configure Resources Settings
You can configure the resource settings for each repository.

To configure a repository resource settings:

 1. On the AEM Navigation Pager dashboard, click Repositories.

 2. In the Repositories List, select a repository, then click Edit.

 3. On the Edit Repository Configuration dialog, click the Resources tab, then enter the settings.
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Setting Action

Copy to target (Update) Select to copy, after submission delivery, any translatable components from the
source that do not exist in the target.

Copy all of the non-
translatable fields during
import

Select to copy all components that cannot be translated, from the source to the
target after submission delivery, synchronizing pages.

Copy to target exceptions Enter a list of specific adaptor nodes' properties or paths to omit coping from
the source to the target:

• Use propertyName

• Use path patterns, such as, */cq:LiveSyncConfig/

Always copy properties
(propertyName@*)

Enter non-translatable properties to synchronize between source and target:

• Use propertyName@sling:resourceType

• If a property has no sling type, use propertyName@*

Delete resources on
target, if they don’t exist
on source

(Optional) Select to delete properties on the target page that are not on the
source page when a submission is delivered.
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Setting Action

File path with translatable
Properties and resource
type mapping

Enter the system path location for translatable components.

Note: The resource must contain a UTF-8 text file without a bill of materials
(BOM).

Custom List Of
translatable properties
and resource type
mapping

Specify the list of translatable fields of AEM resources being sent to Project
Director (PD) for translation. This section allows you to specify the translatable
resources without the need to use a configuration file. Entries should be one
per line in the following format:

• The propertyName@sling:resourceType

• If the sling type is not in the same node as the propertyName, enter the
path to it, such as, parentNode/propertyName@sling:resourceType.

• Enter paths used to restrict a translatable property to certain pages, such
as, pageName/body/leftCol/text@sling:resourceType.

• Enter wildcards for use in generalizing the configuration, such as, text@*
or products/*/label*@*

• If a property has no sling type, enter propertyName@* or
propertyName@**

• If a property has multiple attributes in JSON format, you can map them
by entering:
propertyName@"attributeName1":"@"@*

propertyName@"attributeName2":"@"@*

...

Always copy property
value into the target page
during export

(Optional) Select to copy all translatable property values from the source in the
target pages when sending a submission.

Always copy to target for
pages without translatable
fields during import

(Optional) Select to copy all selected pages after submission delivery, including
those pages with no content to translate.

 4. Click Actions > Save.

The repository resource settings are configured.
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Configure Blocked Resources Settings
To configure blocked resources settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the Blocked Resources tab, then enter your settings.
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Setting Action

Blocked resource types
file path

Enter this file path to override any configuration set for the Blocked resource
type in the user interface.

Note: Use this method of blocking to include all properties listed in grey in the
user interface display of your file.

Custom blocked resource
type mapping

Enter the type of resources or resource paths in AEM restricted from
submissions sent to Project Director (PD).

Note: This entry allows the user to specify the non-translatable resources
without the need to use a configuration file.

Block following nodes to
be synced up on import

Enter the source nodes on AEM not synchronized with target nodes on import.

Block following nodes/
properties not to be
deleted on import

• Enter the paths for nodes from the target that do not exist in the source
that the adaptor does not delete.

• Enter the type of AEM resources for nodes from the target that do not
exist in the source that the adaptor does not delete.

Note: This only applies when Delete resources on target, if they don’t exist
on source is selected.
 

Block import on Nodes/
properties by filter:
(propertyName=value)

Enter filters to block importing translated content on specific nodes. The
adaptor looks for the target node property name in one of the nodes and, if
matched, it prevents the content import.

Include blocking children
nodes of parent that has
the filter

Select to allow extending the blocking of content import on the children
nodes from the blocked parent nodes as defined in Block import on Nodes/
properties by filter... above.

 5. Click Actions > Save.

The blocked resources settings are configured.

Configure Tags Settings
To configure the tags settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.
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 3. In the Repositories List, select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the Tags tab.

Setting Action

Copy tags to target
(update)

Select to enable the copy of source tags to the target.

Send tags to translation Select to send translating standard jcr:tags or automatically create missing
target tags during the GlobalLink translation update workflow.

Tag types mapping file
path

Enter the file path with standard tags.

Note: If a tag-types mapping file path is entered, the Custom tag types
mapping is ignored.

Custom tag types
mapping

Enter non-standard tags that should be translated.
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 5. Click Actions > Save.

The tags settings are configured.

Configure Tag Repositories
If you want to be able to submit tags for translation, you must configure the tag repositories.

To configure tag repositories:

 1. On the AEM Navigation Pager dashboard, click Repositories.

 2. In the Repositories List, select a content site repository, then click Create.

 3. On the New Repository dialog, click the General tab.

Required fields are marked with a red asterisk.
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 4. Provide the following information:

• Repository Path—Location path where the DAM assets folders are, such as,

◦ AEM 6.3—/etc/tags

◦ AEM 6.4, 6.5—/content/cq:tags

• Target Rules—Rules the adaptor uses to allocate translations, in the form
$PROPERTY(@replace($PROPERTY,$PROPERTY.$TGT_LANG))

 5. Click the Resources tab, then configure the Custom resource type mapping with the translatable fields.
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 6. Click the Languages tab, then configure each language mapping with source and target languages.

 7. Click the Tags tab.
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 8. Select the following options:

• Copy tags to target (update)

• Submit tags to translation

• (Optional) Custom Tag language mapping for localizing the tag property to a different locale for Adobe
standards compliance

 9. Click Actions > Save.

The tag repository is configured.

Configure References Settings
You can configure the handling of referenced components.

To configure the references settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.
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 2. Click Repositories.

 3. In the Repositories List, select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the References tab.

Setting Action

Send referenced pages to
translation

Select to enable translation of referenced components when the referencing
page is sent for translation. This causes the referenced component to be sent
for translation and delivered to its target location.
If using Send referenced pages to translation and Link Rewriting, enter the
following in the Resources configuration Custom resource type mapping
entry field: path@foundation/components/reference.
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Setting Action

Reference types mapping
file path

Enter the file path with standard reference types.

Note: If a reference types mapping file path is entered then the Custom
reference types mapping will be ignored.

Custom reference types
mapping

Enter your non-standard reference types.

Children levels deep Enter the number of levels for recursively searching the page for references.
This defaults to one.

Consider references with
the following filters

Enter the fields for filtering the page references.

 5. Click Actions > Save.

The references settings are configured.

Configure Languages Settings
You can configure language mapping for each repository.

To configure repository languages:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. Select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the Languages tab.
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Setting Action

Language mapping file Enter the path to the language mapping file.

Note: If a language mapping file is entered then the Custom language
mapping is ignored.

Custom language
mapping

(Optional) Enter specific language codes in the format <Display Name>@<AEM
code>@<PD code>.
Examples:

• English@en@en-US

• German@de@de-DE

• French@fr@fr-FR

Note: Both the AEM and Project Director (PD) codes are case-sensitive.

Enable Workflow Target
Languages

Select to enable the auto-translation workflow.

Workflow Target
Languages

Enter languages for the auto-translation workflow, such as French@fr-FR.

 5. Click Actions > Save.
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The languages settings are configured.

Configure Auto Submission Settings
You can specify the handling of automated submissions.

To configure auto submission settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a repository, then click Edit.
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 4. On the Edit Repository Configuration dialog, click the Auto Submission tab.

Required field is marked with a red asterisk.

Setting Action

Root path Enter the AEM node path for auto submission after creation or modification.

Type Select a submission type:

• Single—Sends only the modified root path page

• Recursive—Sends the modified root path page and all child pages

Set Time Specify your submission scheduling:

• Specific Time—Select to use a specific time.

• Scheduler Period—Select to use auto-submission.

Scheduler Period Select the frequency in minutes to have AEM poll PD to automatically submit
content. Leave this blank if you are not using auto-submission.

Note: This is only effective if Set Time is Scheduler Period.

Days Select your auto-submission days and hours when you have selected Specific
Time.

Auto submission target
languages

Enter the languages for target submissions. All languages should be listed in
language mapping for the selected repository.
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Setting Action

Consider nodes with the
following filters

List date filters or a property and value that, when included in a node, include
the content of these nodes and their children in the translation.

Ignore nodes with the
following filters

List a property and value that, when detected in a target node, prevent any
action on the target node and its children, not just a single property.

 5. Click Actions > Save.

The auto submission settings are configured.

Configure Notifications Settings
You can configure site repository notifications to provide submission status.

 If your site requires different configurations, you can create additional repositories defined by unique
root paths. Any content that does not belong to a user defined repository retains default repository
settings.

Your configuration only applies to the selected repository.

To configure notifications settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. Select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the Notifications tab.
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Setting Action

Send e-mails about successful send/receive for
current repository

Select to enable notifications for successful send or
receive submissions.

Send e-mails about errors in current repository Select to enable submission error notifications.

Send e-mails to AEM user which created
submission

Select to enable notifications to the AEM user
creating submissions.

Recipients of adaptor messages Enter e-mail addresses to receive notifications.

 5. Click Actions > Save.

The notifications settings are configured.

Configure DAM Assets Settings
You can specify the handling of repository Digital Assets Management (DAM).

To configure repository DAM assets:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repository.
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 3. In the Repositories List, select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the DAM Assets tab.

Setting Action

Send DAM assets to
translation

Select to send DAM metadata for translation. The translatable value should be
a property under the node. For example, the description node has property
en, which will be translated into property zh.

Asset properties for
translation

Enter asset properties for translation. For example, description or
dc:description if the languages property of description is not already created.

Send binary files to
translation

Select to send the DAM file binaries for translation. This can be for files either
inserted into a page or you can use the Resource Types page to select them
separately.
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Setting Action

Binary file types with
classifier

Enter the list of file types to be translated, in the format of
jcr:mimeType@PDclassifier. To determine jcr:mimeType, refer to
the jcr:content node of your original file. PDclassifier is the file type name
configured in Project Director (PD).

Secondary Binary file
types to be included with
Translation

Enter the list of additional file types, such as, thumbnails of a PDF
file. Contact your GlobalLink representative for the entry format of the
jcr:mimeType@PDclassifier in the file type name.

Import and add target
variations under the same
content fragment

(Optional) Select to import the translated content on a variation of the content
fragment according to the target locale.

 5. Click Actions > Save.

The DAM assets settings are configured.

Configure DAM Repositories
If you want to be able to submit assets for translation, you must configure the DAM repositories.

To configure DAM repositories:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a content site repository, then click Create.

 4. On the New Repository dialog, click the General tab.
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Required fields are marked with a red asterisk.

 5. In the field Repository Path, enter the location path where the DAM assets folders are, such as:

/content/dam/we-retail

 6. In the field Target Rules, enter the rules the adaptor uses to allocate translations:

• If you have a language folder structure—

$PATH(@replace($SRC_LANG,$SRC_LANG))

• If you intend the DAM translation to be in the same folder—

$FILE_NAME(@replace($EXTENSION,-$TGT_LANG$EXTENSION))

 7. Click Actions > Save.

Your DAM assets settings are saved.

 8. Click the Languages tab, then configure the various language mappings as source and target languages.
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 9. Click the Dam Assets tab, then modify the following fields:

• Select Send Dam assets for translation and in Asset properties for translation, list the different
metadata properties required for translation, such as, dc:title, dc:description

• Select Send binary files to translation and in Binary file types with classifier, list the different
metadata properties required for translation, such as:

◦ image/jpeg@Non-parsable (image assets)

◦ image/png@Non-parsable (image assets)

◦ application/pdf@Non-parsable (pdf assets)

◦ text/html@ClassifierName (content fragments)
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 10. Click Actions > Save.

The DAM repository is configured.

Configure DAM Workflow Wait Time
When importing translated content for DAM assets AEM triggers generic workflows. These generic workflows can
take excessive time to execute, depending on the asset size. You can configure a wait time for DAM asset import.

To configure DAM workflow wait time:

 1. In CRXDE, browse to /apps/globallink-adaptor/config/.

 2. Create a node named customConfig.

 3. Add the property named damWaitTime and set it to 90000.

This is the time in milliseconds that the adaptor is to wait for the DAM workflows to begin importing the each
asset's content.
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 4. Save the changes in CRXDE.

The DAM workflow wait time is configured.

Configure Link Rewriting Settings
You can configure the repository to enable and specify the handling of link rewriting.

To configure repository link rewriting settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a repository, then click Edit.
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 4. On the Edit Repository Configuration dialog, click the Link Rewriting tab.

Setting Action

Enable Link Rewriting Select to enable the rewrite of any links within property values with the source
language code according to the target rules to include the target path instead.
This only recognizes /content/... strings.

Blocked Resources Enter any resource properties that are not to be rewritten.

Enable Custom Link
Rewriting

Select to enable custom link writing. This recognizes link references in Rich
text properties and multi-line properties.
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Setting Action

Custom Link Mappings Enter the specific properties for rewrite using the following syntax and pattern:

• propertyName@startOfLink@endOfLink@sling:resourceType

◦ property name—The first part of the pattern

◦ beginning of a link—The second part of the pattern

◦ end of a link—The third part of the pattern

◦ sling:resourceType—The fourth and last part of the pattern
For example:

• Source—link:../en/page.html"
Custom Link Config—property@"link":"@"@*

• Source—<a href="="../en/page.html" </a>
Custom Link Config—text@href="@"@*

Blocked Nodes
from link rewriting
(based on filters):
(propertyName=value)

Enter filters to block link rewriting on specific nodes. The adaptor looks for the
target node property name in one of the nodes and, if matched, it prevents the
link rewriting.

Include blocking children
node of parent that has
the filter:

Select to allow extending the blocking of link rewriting on the children nodes
from the blocked parent nodes as defined in Blocked Nodes from link
rewriting... above.

Allow Synchronization
Jobs to Use Regular and
Custom Link Rewriting:

Select this checkbox to have synchronization jobs use the link rewriting
configuration.

 5. Click Actions > Save.

The link rewriting settings are configured.

Configure TM Update Settings
You can configure TM update settings to automate updates to Project Director (PD) for a repository.

To configure TM update settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.
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 3. In the Repositories List, select a repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the TM Update tab.

Required field is marked with a red asterisk.

Enable TM update Select to enable automatic TM updates to Project Director (PD).

Project name Enter the default PD project name.

 5. Click Actions > Save.

The TM update settings are configured.

Configure Workflow Review Settings
You can configure the repository to map AEM reviewer and publisher user groups to each target language and all
be included in the delivery of workflows.

To configure workflow review settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.
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 3. In the Repositories List, select a content site repository, then click Edit.

 4. On the Add Repository Configuration dialog, click the Workflow Review tab.

Setting Action

Enable Reviewers on workflow for translated
content

Select to enable support for reviewers.

List of languages and user groups Enter the language locale and list the AEM translation
reviewing user groups. For example:
de@reviewers-de
fr@reviewers-fr
Where de is the language locale and reviewers-fr is a
valid AEM user group.

Enable Publishers on workflow for translated
content

Select to enable support for publishers.
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Setting Action

List of languages and user groups Enter the language locale and list the AEM translation
publishing user groups. For example:
de@publishers-de
fr@publishers-fr
Where de is the language locale and publishers-fr is a
valid AEM user group.

 5. Click Actions > Save.

The workflow review settings are configured.

Configure Commerce Settings
You can configure the repository to map AEM reviewer and publisher user groups to each target language to
include them in the delivery of workflows.

To configure workflow review settings:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a content site repository, then click Edit.

 4. On the Add Repository Configuration dialog, click the Commerce tab.
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Enter a custom character string to show as the item name when creating a submission for commerce products.

 5. Click Actions > Save.

The commerce settings are configured.
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8. Extend Target Rules
You can extend the feature of target rules to apply to different scenarios.

If your source content is in an English Master folder such as,

/content/we-retail/language-masters/en/experience/arctic-surfing-in-lofoten

And the content needs to be translated into specific region folders, such as—

/content/we-retail/america/de/experience/arctic-surfing-in-lofoten
/content/we-retail/america/fr/experience/arctic-surfing-in-lofoten

To allocate the translations into the /content/america/ folder use the following target rule:

$PATH(@replace(language-masters/$SRC_LANG,america/$TGT_LANG))

If your source content is in an English Master folder such as,

/content/we-retail/language-masters/en/experience/arctic-surfing-in-lofoten

And the content needs to be translated into specific country folders per language, such as—

/content/we-retail/america/de/de/experience/arctic-surfing-in-lofoten
 (Germany Folder)
/content/we-retail/america/ca/fr/experience/arctic-surfing-in-lofoten
 (Canada Folder)

To allocate the translations for each AEM target locale, use the following target rules:

de:$PATH(@replace(language-masters/$SRC_LANG,de/$TGT_LANG))
fr:$PATH(@replace(language-masters/$SRC_LANG,fr/$TGT_LANG))
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9. Workflows Configuration
You can configure custom workflows as well as AEM 6.3, 6.4, and 6.5 workflows to submit content for translation.

Create Custom Workflows
GlobalLink Project Director (PD) AEM Connect Plus includes a sample AEM workflow that triggers translations.
You can use this as a template in creating custom workflows.

To create a custom workflow:

 1. Go to CRXDE.

 2. For AEM 6.3, open the file:

http://localhost:4502/crx/de/index.jsp#/etc/workflow/scripts/
   globallink-adaptor/globallink-adaptor-test.ecma

 3. For AEM 6.4 and 6.5, open the file:

http://localhost:4502/crx/de/index.jsp#/apps/workflow/scripts/
   globallink-adaptor/globallink-adaptor-test.ecma

 4. Modify the English and target locales in accordance with your repository configuration.

 5. Modify the PD project code.

 6. Save your changes.

 7. Go to:

http://localhost:4502/libs/cq/workflow/admin/console/content/models.html
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 8. Select the installed workflow, then click Edit.

 
9. On the Workflow modeler, select the GlobalLink Translation step and click .

 10. Click Process Step, then select a step property:

a) GlobalLink Translation (Single) - Granite—Select to submit the content of one page for translation.
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b) GlobalLink Translation (Recursive) - Granite—Select to submit the content of a page and sub-pages for

translation in one single file.

c) GlobalLink Translation (Recursive Split) - Granite—Select to submit the content of a page and sub-

pages for translation in separate files.

 11. Click Done.

The custom workflow is created.
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Test Custom Workflow
You should test your new custom workflow.

To test your workflow:

 1. Select the workflow, then click Start Workflow.

 2. On the Run Workflow dialog, search for and select Payload.

 3. On the Select Path dialog, select the actual path of your custom workflow.
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 4. Click OK.

 5. Click Run Workflow.

The submission is created and listed on the dashboard under the name of the root path.



 

Copyright © 2020 Translations.com, Inc. Confidential Page 67 of 81

10. Create i18n Dictionary Repositories
You can create and maintain your own, private internationalization (i18n) dictionary.

To create an i18n dictionary:

 1. Create a repository with the dictionary root as its path.

 2. Configure sling:message@** as the translatable resource.

The i18n dictionary repository is created.

Configure i18n Dictionaries as JSON Files
When your private dictionary has a JSON file structure, you must configure it for translation.

To configure your JSON dictionary:

 1. Create a repository with the dictionary root as its path.

 2. Configure the target rule:

$FILE_NAME(@replace(($SRC_LANG$EXTENSION, -$TGT_LANG$EXTENSION))

 3. Save the repository.

The i18n dictionaries are configured as JSON Files.
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11. Configure Error Notifications
To provide error related email notifications, the AEM email settings must be configured as described:

 1. Go to:

http://localhost:4502/system/console/configMgr/
   com.day.aem.mailer.DefaultMailService

 2. Enter the parameters listed in the following table.

Parameters Description

SMTP Server Host
Name

Enter your provider's host name. For example, Gmail SMTP is smtp.gmail.com

SMTP Server Port Enter a user e-mail address.

SMTP Password Enter the user account password.

FROM Address Enter the e-mail address for use in the From: field.

Gmail Config Select SMTP use SSL.

Emitter Config Select Send Emails and enter the e-mail addresses.

 Every email addressee receives one email per error. Email notifications may not work on non-
Windows installations.
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12. Configure Adaptor Logs
To configure your adaptor logs, you must modify the paths in the following two properties files:

 1. Edit the path stored in the following properties file:

/apps/globallink-adaptor/config/
        org.apache.sling.commons.log.LogManager.factory.config-PD2/
        org.apache.sling.commons.log.file

 2. Edit the path stored in the following properties file:

/apps/globallink-adaptor/config/
        org.apache.sling.commons.log.LogManager.factory.writer-PD2/
        org.apache.sling.commons.log.file

The adaptor logs are configured.
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13. Content Fragments Configuration
To permit the adaptor to include the CMS content fragments, you must configure the Content Fragments as
described here using the Edit Repository Configuration dialog.

Include CMS AEM 6.3.0 Fragments
To include CMS AEM 6.3.0 fragments:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repository.

 3. In the Repositories List, select a content site repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the DAM Assets tab.
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 5. Select the Send binary files to translation.

 6. On the Binary file types with classifier enter text/html@PDclassifier.

Where, PDclassifiier is the file type name as configured in Project Director (PD).

 7. Click Actions > Save.

The content fragments from AEM 6.3.0 are set for inclusion in submissions.

Include CMS AEM 6.4.0 and 6.5.0 Fragments
To include CMS AEM 6.4.0 and 6.5.0 fragments:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repository.

 3. In the Repositories List, select a content site repository, then click Edit.
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 4. On the Edit Repository Configuration dialog, click the DAM Assets tab.

 5. Select the Send DAM assets to translation.

 6. On the Asset properties for translation, enter the content fragment properties needed for translation.

These properties are found in:

/content/dam/we-retail/en/experiences/arctic-surfing-in-lofoten/
   arctic-surfing-in-lofoten/jcr:content/data/master

 7. Click Actions > Save.

The CMS AEM 6.4.0 and 6.5.0 fragments are set to be included in submissions.
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14. Experience Fragments Configuration
To permit the adaptor to include the CMS experience fragments, you must use the Edit Repository
Configuration dialog.

Include Experience Fragments from Page
To include experience fragments within a page:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repository.

 3. In the Repositories List, select a content site repository, then click Edit.

 4. On the Edit Repository Configuration dialog, click the References tab.

 5. Select the Send referenced pages to translation.

 6. On the Custom references types mapping enter your experience fragment property path and resource type.

For example:

fragmentVariationPath@gl_demo/components/content/experiencefragment

 7. Click Actions > Save.
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The page experience fragments are set for inclusion in submissions.

Configure Experience Fragments Repositories
If you want to submit experience fragments for translation, you must create a repository similar to a Site
repository.

To configure experience fragment repositories:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a content site repository, then click Create.
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 4. On the New Repository dialog, click the General tab.

Required fields are marked with a red asterisk.

 5. In the field Repository Path, enter the location path of the Experience Fragments folders, such as:

/content/experience-fragment/we-retail

 6. In the field Target Rules, enter the rules the adaptor uses to allocate translations.

For example, for a language folder structure, enter:

$PATH(@replace($SRC_LANG,$SRC_LANG))

 7. Click the Languages tab, and configure the required language mappings as source and target languages.

 8. Click Actions > Save.

Your experience fragments repository is configured.
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15. Campaigns Configuration
To permit the adaptor to include the CMS Campaign content, you must use the Edit Repository Configuration
dialog.

Configure Campaign Repositories
If you want to be able to submit Campaign content for translation, you must use the Edit Repository
Configuration dialog.

To configure Campaign content repositories:

 1. On the AEM Navigation Pager dashboard, click GlobalLink Translation.

 2. Click Repositories.

 3. In the Repositories List, select a content site repository, then click Create.

 4. On the New Repository dialog, click the General tab.
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Required fields are marked with a red asterisk.

 5. In the field Repository Path, enter the location path of the Campaign content folders, such as:

/content/campaigns/we-retail

 6. In the field Target Rules, enter the rules the adaptor uses to allocate translations.

For example, for a language folder structure, enter:

$PATH(@replace($SRC_LANG,$SRC_LANG))

 7. Click the Languages tab, and configure the required language mappings as source and target languages.

 8. Click Actions > Save.

Your Campaign content repository is configured.
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16. AEM Rollout Configuration
When configuring MSM on AEM, you can create an AEM custom rollout configuration to submit translation
changes made from the source, Blueprint, to the target, the live copy.

Create a Custom Rollout on AEM 6.3.0
You can create a custom rollout for AEM 6.3.0.

To create a custom rollout:

 1. Go to:

http://localhost:4502/miscadmin#/etc/msm/rolloutconfigs

 2. Select Roll Configurations, then create a New Page and name it GlobalLink Rollout.

 3. Go to crxde/msm at:

http://localhost:4502/crx/de/index.jsp#/etc/msm/rolloutconfigs

 4. Expand Pushonmodify > jcr:content.

 5. Copy all child pages from here to GlobalLink Rollout.

 6. Select jcr:content and create a new node called workflow. You must set this to cq:LiveSyncAction.

 7. Create one more property named target with the value:

/etc/workflow/models/globallink-adaptor/globallink-translation-
   single-granite/jcr:content/model

 8. Click Properties on one of the Live Copy sites on AEM.
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 9. Click the Live Copy tab and un-select Inherit Rollout Configs from Parent, then select GlobalLink Rollout
configuration from the Rollout Configs list.

 10. Save all the changes.

The custom rollout is created.

Create a Custom Rollout on AEM 6.4.0 and 6.5.0
You can create a custom rollout for AEM 6.4.0 and 6.5.0.

To create a custom rollout:

 1. Go to:

http://localhost:4502/crx/de/index.jsp#/libs/msm/wcm/rolloutconfigs

 2. Create a new node of type cq:RolloutConfig, naming it GlobalLink Rollout.

 3. Go to GlobalLink Rollout and create the properties:

• cq:trigger and set it to rollout

• jcr:title and set it to GlobalLink Rollout
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 4. Save CRXDE.

 5. Expand Pushonmodify > jcr:content and copy all child pages to GlobalLink Rollout.

 6. Select jcr:content, then create a new node called workflow and set it to cq:LiveSyncAction.

 7. Create one more property named target and set it to:

/var/workflow/models/globallink-adaptor/globallink-
   translation-single-granite/

 8. Click Properties on one of the Live Copy sites on AEM.

 9. Click the Live Copy tab, then un-select Inherit Rollout Configs from Parent and select the GlobalLink
Rollout configuration from the Choose Rollout Config drop-down list.
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 10. Save all the changes.

The custom rollout is created.
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